ECHO360 Service Disruption
Incident Report for DoIT
Resolved
Echo has identified and addressed a root cause for the Echo360 North America service disruption.
Posted Sep 14, 2018 - 16:49 EDT
Monitoring
Echo has identified and addressed a root cause for the Echo360 North America service disruption. Service has been restored and we are monitoring the system at this time. We will provide an all-clear when we are satisfied with system stability and will follow up with a root cause analysis.
Posted Sep 14, 2018 - 11:51 EDT
Investigating
Unable to connect, getting "No institutions were found for [user email]". Echo360 website says "Experiencing an issue". Admins notified.
Posted Sep 14, 2018 - 10:35 EDT
This incident affected: Student and Faculty Services (Echo360).