MP2 performance issues

Incident Report for DoIT

Resolved

Maintenance has been Completed for Performance Issue Resolution
Posted May 13, 2026 - 16:11 EDT

Investigating

Please be advised that MP2 related applications are currently experiencing performance related issues, specifically with CPR, Project Requests and BI Reporting.
Posted May 11, 2026 - 15:03 EDT
This incident affected: Business Systems (BI Launch Pad (formerly InfoView), Construction Project Management).