Cherwell Latency
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Jul 09, 2020 - 10:26 EDT
Investigating
We are currently investigating this issue with the vendor.
Posted Jul 09, 2020 - 10:20 EDT
This incident affected: IT Service Portal (service.stonybrook.edu).