DUO Security Two-Factor Authentication
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 16, 2018 - 12:27 EDT
Investigating
Duo is currently experiencing issues which may result in users being unable to access services which use Duo for two-factor authentication. This includes the campus VPN, RD Gateway, Titanium terminal server and Citrix NetScaler VPN used for accessing PeopleSoft related databases and services.
Posted about 2 months ago. Oct 16, 2018 - 11:39 EDT
This incident affected: Accounts and Passwords (DUO Security Two-Factor Authentication).