SOLAR
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 22, 2018 - 21:41 EDT
Investigating
Payments made through SOLAR are not bring processed. System Administrators are looking into the issue.
Posted about 2 months ago. Oct 22, 2018 - 19:39 EDT
This incident affected: SOLAR.