Goo
Incident Report for DoIT
Resolved
UPDATE 4:07 3/22/17 Gmail issue has been resolved
Posted Mar 22, 2017 - 05:05 EDT
Update
UPDATE: 3:53 AM 3/22/17 Per email from Google, "Our team is continuing to investigate this issue."
Posted Mar 22, 2017 - 04:00 EDT
Investigating
Per email from Google, "We're investigating reports of an issue with Gmail. We will provide more information shortly."
Posted Mar 22, 2017 - 03:10 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail).