Blackboard Outage
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted May 10, 2021 - 15:36 EDT
Investigating
We are currently investigating this issue.
Posted May 10, 2021 - 15:02 EDT
This incident affected: Student and Faculty Services (Blackboard).