Adobe Connect doesn't load
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted about 2 months ago. Sep 26, 2017 - 13:12 EDT
Identified
When trying to connect to Adobe Connect (SB Connect), please make sure you have the latest Adobe Connect plug in installed.

For more information, visit: https://helpx.adobe.com/adobe-connect/connect-downloads-updates.html
Posted 2 months ago. Sep 11, 2017 - 13:28 EDT
This incident affected: Collaboration and Publishing (SBConnect (Adobe Connect Web Conferencing)).