Google Sheets
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 12, 2017 - 13:09 EDT
Update
And Google Drive as well
Posted 2 months ago. Sep 12, 2017 - 12:21 EDT
Update
Google indicates this issue effects Docs, Calendar, and GMail as well.
Posted 2 months ago. Sep 12, 2017 - 12:20 EDT
Investigating
Per Google; "Status: Service disruption
We're investigating reports of an issue with Google Sheets. We will provide more information shortly.
Users have reported slowness and connectivity errors
September 12, 2017 11:54:00 AM DST
Posted 2 months ago. Sep 12, 2017 - 12:08 EDT
This incident affected: G Suite (Google Apps) (Google Apps Gmail, Google Apps Calendar, Google Apps Docs, Google Apps Sheets).