SBU Reporting unavailable.
Incident Report for DoIT
Resolved
Wrong system identified for problems.
Posted 2 months ago. Oct 10, 2018 - 06:58 EDT
Investigating
Access to service is unavailable. System Administrators working on a resolution.
Posted 2 months ago. Oct 10, 2018 - 06:56 EDT
This incident affected: Business Systems (SBU Reporting).