Google Drive
Incident Report for DoIT
Resolved
The problem with Google Drive should be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Google, and we are making continuous improvements to make our systems better.

Please have affected users re-authenticate to use Drive File Stream.
Posted Jan 22, 2020 - 15:08 EST
Monitoring
Google Drive service has already been restored for some users, and we expect a resolution for all users in the near future. Please note this time frame is an estimate and may change. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

Users should now be able to log in to Drive File Stream.
Posted Jan 22, 2020 - 14:57 EST
Investigating
We're investigating reports of an issue with Google Drive. We will provide more information shortly. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

This issue only affects Drive File Stream.

As a workaround, use the Drive Web interface.
Posted Jan 22, 2020 - 14:31 EST
This incident affected: G Suite (Google Apps) (Google Apps Drive).