Department Shared Folders
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 06, 2019 - 09:55 EDT
Investigating
Access to "File Server 3" is unavailable. System Administrators working on a resolution.
Posted 5 months ago. Jun 06, 2019 - 06:05 EDT
This incident affected: Servers, Storage and Backups (Department Shared Folders).