Blackboard Disruption
Incident Report for DoIT
Resolved
DoIT Staff have Identified the issue affecting Blackboard logins and resolved the issue.
Posted Nov 08, 2017 - 12:39 EST
Investigating
DoIT Staff is currently investigating an issue where users cannot log into Blackboard.
Posted Nov 08, 2017 - 12:03 EST
This incident affected: Student and Faculty Services (Blackboard).