Possible DUO issue
Incident Report for DoIT
Resolved
Per DUO, incident has been resolved
Posted Feb 26, 2021 - 12:20 EST
Update
DUO reports; "All Deployments: Intermittent Phone and SMS Delivery Delays; Update - We are seeing successful delivery of calls for Phone Callback authentications and are still investigating issues with SMS delivery for some customers. Feb 26, 11:27 EST"
Posted Feb 26, 2021 - 11:51 EST
Investigating
Per DUO status; "Investigating - We are currently investigating an issue causing phone and SMS delivery issues on all of our deployments and are working to correct the issue as soon as possible." Users may see delays in logging in authorizations.
Posted Feb 26, 2021 - 11:03 EST
This incident affected: Accounts and Passwords (Duo Security Two-Factor Authentication).