Lotus Notes
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 31, 2017 - 09:07 EDT
Investigating
Access to Notes2 is unavailable. Working on a resolution
Posted 3 months ago. Aug 31, 2017 - 09:03 EDT
This incident affected: Collaboration and Publishing (Office 365).