IT Service Portal
Incident Report for DoIT
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 13:42 EST
Investigating
We are currently investigating intermittent issues with submitting IT tickets via the self-service portal.
Posted Jan 09, 2020 - 14:42 EST
This incident affected: IT Service Portal (service.stonybrook.edu).