Google Apps Issue
Incident Report for DoIT
Resolved
The issue with Google Docs, Google Drive and Google Sheets has been resolved.
Posted May 15, 2017 - 18:55 EDT
Investigating
Limited availability in Google Docs, Google Drive & Sheets is being investigated.
Posted May 15, 2017 - 16:00 EDT
This incident affected: G Suite (Google Apps) (Google Apps Drive, Google Apps Docs, Google Apps Sites).